Excel для продвинутых: подборка полезных трюков

Схематичное изображение таблицы Excel Полезные советы

Microsoft Excel, пожалуй, лучшая офисная программа из когда-либо созданных. На ней держатся целые отрасли экономики, так что, виртуозно овладев этим инструментом, вы сразу заметите, что дела у вашего бизнеса идут в гору.

9 функций Excel, которые могут быть вам полезны

Кроме множества базовых приёмов работы с этой программой, которые вы наверняка уже знаете, полезно изучить некоторые хитрости «для продвинутых», которые сделают вас на голову выше всех остальных. Так что, если хотите впечатлить своих боссов и разгромить конкурентов, вам пригодятся эти 9 хитрых функций Excel.

Электронная таблица Excel
Excel обладает массой функций

ВПР

Эта функция позволяет быстро найти нужное вам значение в таблице. Например, нам нужно узнать финальный балл Бетт, мы пишем: =ВПР(“Beth”,A2:E6,5,0), где Beth – имя ученика, A2:E6 – диапазон таблицы, 5 – номер столбца, а 0 означает, что мы не ищем точного соответствия значению.

Функция очень удобна, однако нужно знать некоторые особенности её использования. ВПР ищет только слева направо, так что, если вам понадобится искать в другом порядке, придётся менять параметры сортировки целого листа. И сли вы выберете слишком большую таблицу, поиск может занять много времени.

Читайте так же:  Как перенести папку "Мои документы" в Windows XP

Функция ИНДЕКС

Отражает значение или ссылку на ячейку на пересечении конкретных строки и столбца в выбранном диапазоне ячеек. Например, чтобы посмотреть, кто стал четвёртым в списке самых высокооплачиваемых топ-менеджеров Уолл-стрит, набираем: =ИНДЕКС(А3:А11, 4).

ПОИСКПОЗ

Функция ПОИСКПОЗ выполняет поиск указанного элемента в диапазоне (Диапазон — две или более ячеек листа. Ячейки диапазона могут быть как смежными, так и несмежными) ячеек и отражает относительную позицию этого элемента в диапазоне.

По отдельности ИНДЕКС и ПОИСКПОЗ не особо полезны. Но вместе они могут заменить функцию ВПР.

Например, чтобы в большой таблице найти, кто является главой Wells Fargo, пишем =ИНДЕКС(А3:А11,ПОИСКПОЗ(«Wells Fargo»,B3:B11,0).

С помощью функции ВПР этого не сделать, потому что она ищет только слева направо. А сочетание двух последних позволяет сделать это очент просто.

3D-сумма

Допустим, вы решили подсчитать, сколько денег вы тратите каждый день, и вести учёт в течение семи недель. Под каждую неделю вы создали отдельный лист, куда по дням заносите расходы на алкоголь, еду и прочие мелочи.

Читайте так же:  jusched.exe - что это такое и как его убрать?

Теперь на вкладке TOTAL (ИТОГО) нам нужно увидеть, сколько и в какой день вы потратили за этот период. Набираем =СУММ(‘Week1:Week7’!B2), и формула суммирует все значения в ячейке B2 на всех вкладках. Теперь, заполнив все ячейки, мы выяснили, в какой день недели тратили больше всего, а также в итоге подбили все свои расходы за эти 7 недель.

$

Одна из самых удобных функций в арсенале Excel, а также одна из самых простых – это знак $. Он указывает программе, что не нужно делать автоматической корректировки формулы при её копировании в новую ячейку, как Excel поступает обычно.

При этом знак $ перед «А» не даёт программе изменять формулу по горизонтали, а перед «1» – по вертикали. Если же написать «$A$1», то значение скопированной ячейки будет одинаковым в любом направлении. Очень удобный приём, когда приходится работать с большими базами данных.

&

Если вы хотите собрать все значения из разных ячеек в одну, вы можете использовать функцию СЦЕПИТЬ. Но зачем набирать столько букв, если можно заменить их знаком «&».

Массивы

Для создания массива или матрицы вам потребуется несколько операций, но они сложнее, чем в случае с обычными формулами, ведь для отображения результата требуется не одна, а несколько ячеек.

Читайте так же:  Как открыть меню "Параметры страницы" в Microsoft Office 2007 (Word, Excel)

Например, давайте перемножим две матрицы. Для этого используем функцию МУМНОЖ (Массив 1, Массив 2). Главное, не забудьте закрыть формулу круглой скобкой. Теперь нажмите сочетание клавиш Ctrl+Shift+Enter, и Excel покажет результат умножения в виде матрицы. То же самое касается и других функций, работающих с массивами, – вместо простого нажатия Enter для получения результата используйте Ctrl+Shift+Enter.

Подбор параметра

Без этой функции Excel целым легионам аналитиков, консультантов и прогнозистов пришлось бы туго. Спросите кого угодно из сферы консалтинга или продаж, и вам расскажут, насколько полезной бывает эта возможность Excel.

Знание этих приёмом поможет вам сэкономить кучу времени при работе с электронными таблицами.

Оцените статью
REMNABOR
Добавить комментарий

Adblock
detector